Screenwash motor

Tips and help requests for your cars electrics. Post your tips help other sort problems out.

Screenwash motor

Postby vauxhallbitz » Thu Mar 28, 2019 8:22 pm

My pump stopped working so I had a spare from a scrap car and thought it would be an easy job, however the replacement one works but does not seen powerful enough. It is pumping water but the rate is not enough when you connect it to the jets.

Anyone had a similar problem?
1958 CA Bedford Dormobile (Porthole)
1960 Vauxhall Cresta PA
1975 Vauxhall Viva E Coupe
User avatar
vauxhallbitz
Brabham Viva
Brabham Viva
 
Posts: 717
Joined: Sat Jul 17, 2010 6:48 pm
Location: Rosyth, Fife , Scotland

Re: Screenwash motor

Postby 1972nail » Thu Mar 28, 2019 10:03 pm

The carbon brushes and the commutator tend to get very dirty and need cleaned up with meths. The brushes are very weak so great care needs to be taken when dismantling the motor not to break them. I gave up repairing the ones I had in the end and just fitted an after market motor.
Editor of the VVOC Magazine ReVival

"When you have a Firenza like mine, who needs any Minis?" copyright David Maxwell 1979.
User avatar
1972nail
Old Nail
Old Nail
 
Posts: 3223
Joined: Sun Aug 07, 2011 4:16 pm
Location: Ballymoney Co Antrim - some say....the World's best place to live!

Re: Screenwash motor

Postby vauxhallbitz » Fri Mar 29, 2019 1:06 am

Sounds like a plan, thanks.
1958 CA Bedford Dormobile (Porthole)
1960 Vauxhall Cresta PA
1975 Vauxhall Viva E Coupe
User avatar
vauxhallbitz
Brabham Viva
Brabham Viva
 
Posts: 717
Joined: Sat Jul 17, 2010 6:48 pm
Location: Rosyth, Fife , Scotland

Re: Screenwash motor

Postby vauxhallbitz » Tue Apr 16, 2019 6:05 pm

OK I am not an idiot and have worked on old cars for many years but I can't get my Screenwash to work.

I took advice and bought an after market pump the same as the one I broke, what could go wrong???

I fitted it tonight but it will not pump water, the motor is working but if will not pump. It is clearly marked IN and OUT so you can't make a mistake.

What am I doing wrong!!!!
1958 CA Bedford Dormobile (Porthole)
1960 Vauxhall Cresta PA
1975 Vauxhall Viva E Coupe
User avatar
vauxhallbitz
Brabham Viva
Brabham Viva
 
Posts: 717
Joined: Sat Jul 17, 2010 6:48 pm
Location: Rosyth, Fife , Scotland

Re: Screenwash motor

Postby droopsnoot » Tue Apr 16, 2019 6:29 pm

If you put a couple of short lengths of pipe on it and stick a voltage across it, does it pump then? I wonder if you've got a blockage somewhere in the pipes on the car.
My real name: Mike. My web site: http://www.firenza.net

My stuff for sale: http://www.firenza.net/forsale.shtml
droopsnoot
Old Nail
Old Nail
 
Posts: 2281
Joined: Mon Oct 31, 2005 2:08 pm
Location: Cheshire

Re: Screenwash motor

Postby 1972nail » Tue Apr 16, 2019 7:18 pm

Some washer pipes have a one way valve on the end that dips into the bottle. Sometimes that can stick closed or get clogged. There may be a pin hole in the pick up pipe or an air leak on the intake joints that allow air in instead of drawing water. You may have to prime the pump to get it working, a quick suck on the outlet pipe may be enough.

As Mike says you could have a blockage, including the jets.
Editor of the VVOC Magazine ReVival

"When you have a Firenza like mine, who needs any Minis?" copyright David Maxwell 1979.
User avatar
1972nail
Old Nail
Old Nail
 
Posts: 3223
Joined: Sun Aug 07, 2011 4:16 pm
Location: Ballymoney Co Antrim - some say....the World's best place to live!

Re: Screenwash motor

Postby vauxhallbitz » Tue Apr 16, 2019 9:09 pm

I fitted new pipe throughout and thought the bore might be too narrow will try on the bench with short pipes tomorrow.
1958 CA Bedford Dormobile (Porthole)
1960 Vauxhall Cresta PA
1975 Vauxhall Viva E Coupe
User avatar
vauxhallbitz
Brabham Viva
Brabham Viva
 
Posts: 717
Joined: Sat Jul 17, 2010 6:48 pm
Location: Rosyth, Fife , Scotland


Return to Electrical help

Who is online

Users browsing this forum: No registered users and 0 guests

cron